Skip to content

[Yarn] パッケージのバージョン指定を変更する

  • yarn

2021-06-30

yarnにて既に存在するパッケージのバージョンを変更したい

以下のように既にpackage.jsonに存在するパッケージのバージョンを変えたい時があるかと思います。

{
  "name": "my-project",
  "description": "xxx",
  "version": "1.0.0",
  "repository": "xxx",
  "author": "xxx",
  "dependencies": {
    "some-package": "^1.2.3"
  }
}

方法

yarn upgrade some-package@2.3.4

yarn upgradeを使うことで変更できます。

結果このようになります。

{
  "name": "my-project",
  "description": "xxx",
  "version": "1.0.0",
  "repository": "xxx",
  "author": "xxx",
  "dependencies": {
    "some-package": "2.3.4" <- バージョンが変更されている。
  }
}
← PrevNext →
  • Motohouse Dev Blog